[K2]

This forum is an archive for the mailing list elecraft@mailman.qth.net (more options) Messages posted here will be sent to this mailing list.
Posts related to the Elecraft K2 and K2/100.
Please put [K2] in the subject.
12345 ... 64
Topics (2219)
Replies Last Post Views
HELP KDSP2 ELECRAFT K2 by iz3asa
0
by iz3asa
K2 Lo p on 10 12m when its cold outside. by EMD
3
by Don Wilhelm-4
K2 + Field Day by aj4tf
0
by aj4tf
K2 100 watt power amp fail and fix by paulb
1
by Bill Coleman-2
K2 Straight key auto detect by Gene N4FZ
23
by Joe Subich, W4TV-4
K2 KPA100 fan replacement? by Sverre Holm (LA3ZA)
0
by Sverre Holm (LA3ZA)
K2 #7261 receive 20m by Don Baucom
3
by Don Wilhelm-4
K2 audio images strong signals 40 meters by paulb
5
by Don Wilhelm-4
Can I measure antenna impedance with K2? by TF3KX
24
by Wes (N7WS)
K2 Control board resistance checks by Paul Huff-3
5
by Don Wilhelm-4
Assembled K2 Misc. Accessory Board available by Lou Voerman W2ROW
1
by Lou Voerman W2ROW
Elecraft K2/10 Upgrade by Rick-N8XI
3
by Phil Wheeler-2
4 MHz oscillator is too high in frequency (K2) by Sverre Holm (LA3ZA)
3
by Sverre Holm (LA3ZA)
K2 Panadapter? by Don Baucom
0
by Don Baucom
[K2] Miscellaneous Accessory Board Project by Dave KW4M
15
by Thomas Taylor-2
[K2] Error in KIO2 Programmers Reference? by Brian - N5BCN
0
by Brian - N5BCN
KPA100 Acoustic Noise by raycollins
1
by Don Wilhelm-4
KDSP2 stopped working, LED always on by Brian - N5BCN
4
by Don Wilhelm-4
K2 - Resonate noise on audio by Jason V
7
by Don Wilhelm-4
KAT100 Power Calibration Problem by JeremyJones
9
by JeremyJones
K2 LCD Issue by donh
2
by luc Favre-2
K2 Won't power on by JeremyJones
29
by JeremyJones
JT modes alignment by F5LCI
3
by Don Wilhelm-4
KS - Serial 7168 officially on the air! by VA2EK
0
by VA2EK
K2 AGC and CAL HI LO value question by Jean-Fran├žois | VA2S...
2
by Jean-Fran├žois | VA2S...
Alignement and Test part II - VCO Test not reading 8 to 10 MHZ range. by VA2EK
2
by VA2EK
[K2] Safely running 100% key-down modes by K1FFX
4
by Bill Coleman-2
K2 / KPA ALC problem. by Chris Kimball
19
by Don Wilhelm-4
Audible thump sound when sending cw on K2 by Don Baucom
2
by Don Baucom
Convert KAT 100-2 back to KAT 100-1 by Bob Whelan
0
by Bob Whelan
k2 #7377 by haircutter@verizon.n...
3
by haircutter@verizon.n...
[k2] Doc download not working for me, are there problems ? by ik1bxn
1
by Don Wilhelm-4
[K2] PA ALC problem on CW by picmaster
4
by picmaster
KPA100 problem with SWR bridge - High SWR by Stan AE7UT
1
by Stan AE7UT
KNB2 - looking for experience with mods that made it effective by Stan AE7UT
7
by OE5CSP-Chris
12345 ... 64