K3 Macro query

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

K3 Macro query

Stewart@twinwood
The following macro runs OK from the K3 Utility program,
but not when assigned to a function key - why ?

TUNEON    MN019;MP001;MN255;SWH16;

73
Stewart G3RXQ
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: K3 Macro query

Mike K2MK
Hi Stewart,

Your macro works here. You probably missed one step. First I entered you macro in the K3 Utility on the Macro tab. I pressed the Edit Macros button and typed it into the field for Macro 8. Next I hit the button labeled "Write Macros 1-8 to K3". Then I hit Save and quit the Utility program.

After that I went to the K3 and brought up CONFIG:MACRO and hit the 8 button. The lower display then showed "MACRO 8". I tapped the M4 button on my K3 in order to save the macro to that button. The lower display then briefly displayed M4T SET. That's it. My K3 goes into tune (and I suppose does the other things in your macro) when I tap my M4 button.

73,
Mike K2MK

Stewart@twinwood wrote
The following macro runs OK from the K3 Utility program,
but not when assigned to a function key - why ?

TUNEON    MN019;MP001;MN255;SWH16;

73
Stewart G3RXQ
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: K3 Macro query

Stewart@twinwood
Hi Mike,
I now have my macro working, but I don't know why.

The only difference is that instead of assigning to M1H SET,
I followed your example and assigned it to M1T SET.

It would appear that there is some conflict between a function key Hold
and a function that uses Hold. Assigning to Tap makes it work.

Very strange...

Thanks for your help.

73
Stewart G3RXQ
On Mon, 2 Jul 2012 07:42:03 -0700 (PDT), Mike K2MK wrote:

> Hi Stewart,
>
> Your macro works here. You probably missed one step. First I entered you
> macro in the K3 Utility on the Macro tab. I pressed the Edit Macros button
> and typed it into the field for Macro 8. Next I hit the button labeled
> "Write Macros 1-8 to K3". Then I hit Save and quit the Utility program.
>
> After that I went to the K3 and brought up CONFIG:MACRO and hit the 8
> button. The lower display then showed "MACRO 8". I tapped the M4 button on
> my K3 in order to save the macro to that button. The lower display then
> briefly displayed M4T SET. That's it. My K3 goes into tune (and I suppose
> does the other things in your macro) when I tap my M4 button.
>
> 73,
> Mike K2MK
>
>
> Stewart@twinwood wrote
>>
>> The following macro runs OK from the K3 Utility program,
>> but not when assigned to a function key - why ?
>>
>> TUNEON    MN019;MP001;MN255;SWH16;
>>
>> 73
>> Stewart G3RXQ
>
>
> --
> View this message in context: http://elecraft.365791.n2.nabble.com/K3-Macro-query-tp7558469p7558474.html
> Sent from the Elecraft mailing list archive at Nabble.com.
> ______________________________________________________________
> Elecraft mailing list
> Home: http://mailman.qth.net/mailman/listinfo/elecraft
> Help: http://mailman.qth.net/mmfaq.htm
> Post: mailto:[hidden email]
>
> This list hosted by: http://www.qsl.net
> Please help support this email list: http://www.qsl.net/donate.html


______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: K3 Macro query

jlbates4
I need some help understanding SWH/SWT commands and assignments to PF[1|2]|M[1-4]keys:

I'm trying to assign a MACRO5 to PF1; but it fails to perform the SWT19 function...  Please see tests below...

Reference K3...KX2 Programmers Reference Guide G1; page 25
TAP       HOLD  nn
XMIT      TUNE  16
ATU Tune  ATU   19

Here are the macros:
MACRO1:  SWH16;
MACRO2:  SWT16;
MACRO3:  SWH19;
MACRO4:  SWT19;
MACRO5:  IS*1500;BW0280;AN1;MN023;MP002;MN255;PC100;SWT19;

When I execute from the K3 Utility Rev 1.16.7.25:
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully

Assign to M[1-4] as TAP (All works as expected)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off  
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully

Assign to M[1-4] as HOLD (ERROR w/MACRO5)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off  
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully EXCEPT SWT19

Assign to PF[1-2] as HOLD (ERROR w/MACRO5)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off  
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully EXCEPT SWT19

K8OI
mailto:jlbates4@gmail.com
(804) 592-1068
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: K3 Macro query

Don Wilhelm
Jim

I do not see the macros in your post, but you first have to assign the
macros to the buttons, and then activate then by using the SWT/SWH
commands listed in the K3 Programmers Reference.  It is a two step process.

73,
Don W3FPR

On 6/2/2017 3:16 PM, jlbates4 wrote:

> I need some help understanding SWH/SWT commands and assignments to
> PF[1|2]|M[1-4]keys:
>
> I'm trying to assign a MACRO5 to PF1; but it fails to perform the SWT19
> function...  Please see tests below...
>
>
>
>
>
> -----
> K8OI
> mailto:[hidden email]
> (804) 592-1068
> --
> View this message in context: http://elecraft.365791.n2.nabble.com/K3-Macro-query-tp7558469p7631362.html
> Sent from the Elecraft mailing list archive at Nabble.com.
> ______________________________________________________________
> Elecraft mailing list
> Home: http://mailman.qth.net/mailman/listinfo/elecraft
> Help: http://mailman.qth.net/mmfaq.htm
> Post: mailto:[hidden email]
>
> This list hosted by: http://www.qsl.net
> Please help support this email list: http://www.qsl.net/donate.html
> Message delivered to [hidden email]
>
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: K3 Macro query

Jim Bates
In reply to this post by Stewart@twinwood
Don et al,
I'm not sure why the entire post didn't come through - (please reference
link:
http://elecraft.365791.n2.nabble.com/K3-Macro-query-td7558469.html#a7631362)

Here's the original post:

I need some help understanding SWH/SWT commands and assignments to
PF[1|2]|M[1-4]keys:

I'm trying to assign a MACRO5 to PF1; but it fails to perform the SWT19
function...  Please see tests below...

Reference K3...KX2 Programmers Reference Guide G1; page 25
TAP       HOLD  nn
XMIT      TUNE  16
ATU Tune  ATU   19

Here are the macros:
MACRO1:  SWH16;
MACRO2:  SWT16;
MACRO3:  SWH19;
MACRO4:  SWT19;
MACRO5:  IS*1500;BW0280;AN1;MN023;MP002;MN255;PC100;SWT19;

When I execute from the K3 Utility Rev 1.16.7.25:
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully

Assign to M[1-4] as TAP (All works as expected)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully

Assign to M[1-4] as HOLD (ERROR w/MACRO5)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully EXCEPT SWT19

Assign to PF[1-2] as HOLD (ERROR w/MACRO5)
Macro Executed  K3 Response
MACRO1:         Manual Tune On/Off
MACRO2:         Enable Transmit On/Off
MACRO3:         Turned ATU On/Off
MACRO4:         Performed Auto Tune Function
MACRO5:         All values/functions complete successfully EXCEPT SWT19



---
Jim Bates
(804) 690-9143

On Fri, Jun 2, 2017 at 8:16 PM, Don Wilhelm <[hidden email]> wrote:

> Jim
>
> I do not see the macros in your post, but you first have to assign the
> macros to the buttons, and then activate then by using the SWT/SWH commands
> listed in the K3 Programmers Reference.  It is a two step process.
>
> 73,
> Don W3FPR
>
> On 6/2/2017 3:16 PM, jlbates4 wrote:
>
>> I need some help understanding SWH/SWT commands and assignments to
>> PF[1|2]|M[1-4]keys:
>>
>> I'm trying to assign a MACRO5 to PF1; but it fails to perform the SWT19
>> function...  Please see tests below...
>>
>>
>>
>>
>>
>> -----
>> K8OI
>> mailto:[hidden email]
>> (804) 592-1068
>> --
>> View this message in context: http://elecraft.365791.n2.nabb
>> le.com/K3-Macro-query-tp7558469p7631362.html
>> Sent from the Elecraft mailing list archive at Nabble.com.
>> ______________________________________________________________
>> Elecraft mailing list
>> Home: http://mailman.qth.net/mailman/listinfo/elecraft
>> Help: http://mailman.qth.net/mmfaq.htm
>> Post: mailto:[hidden email]
>>
>> This list hosted by: http://www.qsl.net
>> Please help support this email list: http://www.qsl.net/donate.html
>> Message delivered to [hidden email]
>>
>>
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Loading...