KAT500 Utility 1.14.4.10 beta test version available on our FTP site

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Dick Dievendorff-4
We have placed a new beta KAT500 Utility (Windows version) on our FTP site.

 

When the KAT500 has been configured for "sleep when idle", configuration
changes were difficult. The new version wakes up the sleeping
microcontroller more reliably.

 

Additionally, the Erase Antenna Tuner Memory function has been moved from a
tab on the Edit Configuration property page to a dialog invoked directly
from a button on the Configuration page.

 

ftp://ftp.elecraft.com/tmp/KAT500/KAT500Utility/KAT500_Utility_Setup_1_14_4_
10.exe

 

You may need to refresh your browser's cache; the file was added just this
morning.

 

73 de Dick, K6KR



______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Stan Gibbs, KR7C
With the new utility, I am still seeing incorrect responses from commands when the oscillator sleep is enabled.  The oscillator does start after one "an;" command, but the correct "AN1;" response does not occur until I send two more "an;" commands.

I would expect to see the correct response after the first "an;" command, as happens when the idle sleep is disabled.

73, Stan - KR7C
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Dick Dievendorff-4
Are you entering these commands from the command tester?   It takes almost 50 msec to wake up the microcontroller and several serial characters will arrive and are lost in that time. If you are entering commands from the command tester, it's better to turn off idle sleep. I have a command macro button set up with SL0;SL; to accomplish this.

The operate page works OK, right?

73 de Dick, K6KR



> On Apr 10, 2014, at 21:11, "Stan Gibbs, KR7C" <[hidden email]> wrote:
>
> With the new utility, I am still seeing incorrect responses from commands
> when the oscillator sleep is enabled.  The oscillator does start after one
> "an;" command, but the correct "AN1;" response does not occur until I send
> two more "an;" commands.
>
> I would expect to see the correct response after the first "an;" command, as
> happens when the idle sleep is disabled.
>
>
>
>
>
> -----
> 73, Stan - KR7C
> --
> View this message in context: http://elecraft.365791.n2.nabble.com/KAT500-Utility-1-14-4-10-beta-test-version-available-on-our-FTP-site-tp7586987p7587005.html
> Sent from the Elecraft mailing list archive at Nabble.com.
> ______________________________________________________________
> Elecraft mailing list
> Home: http://mailman.qth.net/mailman/listinfo/elecraft
> Help: http://mailman.qth.net/mmfaq.htm
> Post: mailto:[hidden email]
>
> This list hosted by: http://www.qsl.net
> Please help support this email list: http://www.qsl.net/donate.html
> Message delivered to [hidden email]
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Stan Gibbs, KR7C
Yes, I was typing the commands on the Command Tester tab.

I notice from my P3's 28.004 oscillator signal that the oscillator is enabled immediately when the Firmware or Operate tabs are selected.  However, the oscillator runs continuously while the Operate tab is selected and turns off after a delay in the case of the Firmware tab.  Is there a reason for this difference?  Sending firmware to the KAT500 with idle sleep enabled seems to work reliably now, even waiting for the oscillator to time-out first.

The Configuration and Command Tester tabs don't enable the oscillator until the user either clicks a configuration button or sends a macro command.  In both cases the oscillator stops after a few seconds of idleness, like the Firmware tab.

Why not simply enable the oscillator (disable the sleep) after the utility has established communications with the KAT500 on startup, and restore the user's Idle Sleep setting on exit?  If users are fiddling with their KAT500 configuration, it doesn't seem like they should be that concerned about the 28.004 signal being present.  If they are using the Operate tab to monitor station operation, then the oscillator signal will be present regardless of the Idle Sleep setting.

However, this begs the question of other apps accessing the KAT500.  IMHO, requiring all of them to send junk commands until they get a reasonable response does not seem like a very reliable strategy.

Is there a hardware mod that could be made that would shift the oscillator out of the 10m band?  That would eliminate the problem altogether, allow the firmware to be simplified and greatly improve the communications reliability.
73, Stan - KR7C
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

tomb18
In reply to this post by Dick Dievendorff-4
Hi
I second the hardware mod.  For programs such as Win4k3suite which poll the Kat keeping the sleep mode on introduces unacceptable delays. So instruct people to turn sleep mode off. 
73s Tom  va2fsq 




-------- Original message --------
From: "Stan Gibbs, KR7C" <[hidden email]>
Date: 11/04/2014  11:26  (GMT-05:00)
To: [hidden email]
Subject: Re: [Elecraft] KAT500 Utility 1.14.4.10 beta test version available on our FTP site
 
Yes, I was typing the commands on the Command Tester tab.

I notice from my P3's 28.004 oscillator signal that the oscillator is
enabled immediately when the Firmware or Operate tabs are selected.
However, the oscillator runs continuously while the Operate tab is selected
and turns off after a delay in the case of the Firmware tab.  Is there a
reason for this difference?  Sending firmware to the KAT500 with idle sleep
enabled seems to work reliably now, even waiting for the oscillator to
time-out first.

The Configuration and Command Tester tabs don't enable the oscillator until
the user either clicks a configuration button or sends a macro command.  In
both cases the oscillator stops after a few seconds of idleness, like the
Firmware tab.

Why not simply enable the oscillator (disable the sleep) after the utility
has established communications with the KAT500 on startup, and restore the
user's Idle Sleep setting on exit?  If users are fiddling with their KAT500
configuration, it doesn't seem like they should be that concerned about the
28.004 signal being present.  If they are using the Operate tab to monitor
station operation, then the oscillator signal will be present regardless of
the Idle Sleep setting.

However, this begs the question of other apps accessing the KAT500.  IMHO,
requiring all of them to send junk commands until they get a reasonable
response does not seem like a very reliable strategy.

Is there a hardware mod that could be made that would shift the oscillator
out of the 10m band?  That would eliminate the problem altogether, allow the
firmware to be simplified and greatly improve the communications
reliability.




-----
73, Stan - KR7C
--
View this message in context: http://elecraft.365791.n2.nabble.com/KAT500-Utility-1-14-4-10-beta-test-version-available-on-our-FTP-site-tp7586987p7587017.html
Sent from the Elecraft mailing list archive at Nabble.com.
______________________________________________________________
Elecraft mailing list
Home: http:/
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

ok1rr
In reply to this post by Dick Dievendorff-4
Windows only, grrr.

73,
Martin, OK1RR
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Eric Swartz - WA6HHQ, Elecraft
Administrator
IT takes us a little longer to get the Mac and Linux versions out after the
Windows utility is fully tested.

Eric
elecraft.com

On 4/11/2014 11:18 AM, Martin Kratoska wrote:

> Windows only, grrr.
>
> 73,
> Martin, OK1RR
> ______________________________________________________________
> Elecraft mailing list
> Home: http://mailman.qth.net/mailman/listinfo/elecraft
> Help: http://mailman.qth.net/mmfaq.htm
> Post: mailto:[hidden email]
>
> This list hosted by: http://www.qsl.net
> Please help support this email list: http://www.qsl.net/donate.html
> Message delivered to [hidden email]

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

ok1rr
Thanks a million, Eric!

73,
Martin, OK1RR

Dne 11.4.2014 21:26, Eric Swartz - WA6HHQ, Elecraft napsal(a):

> IT takes us a little longer to get the Mac and Linux versions out after
> the Windows utility is fully tested.
>
> Eric
> elecraft.com
>
> On 4/11/2014 11:18 AM, Martin Kratoska wrote:
>> Windows only, grrr.
>>
>> 73,
>> Martin, OK1RR
>> ______________________________________________________________
>> Elecraft mailing list
>> Home: http://mailman.qth.net/mailman/listinfo/elecraft
>> Help: http://mailman.qth.net/mmfaq.htm
>> Post: mailto:[hidden email]
>>
>> This list hosted by: http://www.qsl.net
>> Please help support this email list: http://www.qsl.net/donate.html
>> Message delivered to [hidden email]
>
>

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KAT500 Utility 1.14.4.10 beta test version available on our FTP site

Bob-270
In reply to this post by Stan Gibbs, KR7C
None yet.  Back on February 24th Wayne mentioned here on the forum that it was
being worked on.

That posting pasted below:

Hang in there a little longer.

73,
Bob
K2TK   ex KN2TKR (1956) & K2TKR

Yes, we're definitely working on a way to move the crystal frequency. (This applies to both the KAT500 and the KXPA100.) I'll post again once we have modification kits ready.

73,
Wayne
N6KR



On 4/11/2014 11:26 AM, Stan Gibbs, KR7C wrote:

> Is there a hardware mod that could be made that would shift the oscillator
> out of the 10m band?  That would eliminate the problem altogether, allow the
> firmware to be simplified and greatly improve the communications
> reliability.
>
>
>
>
> -----
> 73, Stan - KR7C
> --
>

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]