KX2 front panel lettering disappearing

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

KX2 front panel lettering disappearing

Stephen G4SJP
Before I take this up with the UK agent for Elecraft, I am curious as to
whether anyone else has experienced the yellow lettering rubbing off,
particularly at the bottom of the front panel?  I have only had my KX2 for
a couple of weeks and just had my first QSOs with it yesterday, so it's not
had any prolonged treatment.  It looks to me as if the lettering at the top
of the panel is fine.  White lettering seems much more robust.

73 Stephen, G4SJP
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KX2 front panel lettering disappearing

wayne burdick
Administrator
Hi Stephen,

We use epoxy ink for panel labeling, which is normally very robust. Our UK dealer should give you a replacement right away. If possible, we'd like to get the panel back for QA analysis.

73,
Wayne
N6KR



On Feb 19, 2017, at 12:42 PM, Stephen Prior <[hidden email]> wrote:

> Before I take this up with the UK agent for Elecraft, I am curious as to
> whether anyone else has experienced the yellow lettering rubbing off,
> particularly at the bottom of the front panel?  I have only had my KX2 for
> a couple of weeks and just had my first QSOs with it yesterday, so it's not
> had any prolonged treatment.  It looks to me as if the lettering at the top
> of the panel is fine.  White lettering seems much more robust.
>
> 73 Stephen, G4SJP


______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KX2 front panel lettering disappearing

Augie "Gus" Hansen
In reply to this post by Stephen G4SJP

On 2/19/2017 1:42 PM, Stephen Prior wrote:
> Before I take this up with the UK agent for Elecraft, I am curious as to
> whether anyone else has experienced the yellow lettering rubbing off,
> particularly at the bottom of the front panel?  I have only had my KX2 for
> a couple of weeks and just had my first QSOs with it yesterday, so it's not
> had any prolonged treatment.

My KX2 arrived with the lower third of the left side downstroke of the M
in the MENU label missing. I have been using the KX2 for antenna testing
in my backyard and have not noticed any degradation of other labels. I
suspect this is a case of a label that just wasn't screened completely
rather than being damaged afterward.

Gus Hansen
KB0YH

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: KX2 front panel lettering disappearing

Stephen G4SJP
Just by way of an update to the screen printing disappearing, the UK dealer
is going to replace the front panel of the KX2 for me.

73 Stephen, G4SJP

On 20 February 2017 at 05:30, Augie "Gus" Hansen <[hidden email]>
wrote:

>
> On 2/19/2017 1:42 PM, Stephen Prior wrote:
>
>> Before I take this up with the UK agent for Elecraft, I am curious as to
>> whether anyone else has experienced the yellow lettering rubbing off,
>> particularly at the bottom of the front panel?  I have only had my KX2 for
>> a couple of weeks and just had my first QSOs with it yesterday, so it's
>> not
>> had any prolonged treatment.
>>
>
> My KX2 arrived with the lower third of the left side downstroke of the M
> in the MENU label missing. I have been using the KX2 for antenna testing in
> my backyard and have not noticed any degradation of other labels. I suspect
> this is a case of a label that just wasn't screened completely rather than
> being damaged afterward.
>
> Gus Hansen
> KB0YH
>
> ______________________________________________________________
> Elecraft mailing list
> Home: http://mailman.qth.net/mailman/listinfo/elecraft
> Help: http://mailman.qth.net/mmfaq.htm
> Post: mailto:[hidden email]
>
> This list hosted by: http://www.qsl.net
> Please help support this email list: http://www.qsl.net/donate.html
> Message delivered to [hidden email]
>
______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:[hidden email]

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to [hidden email]