KX3 Does Not Power On with External Power Supply

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

KX3 Does Not Power On with External Power Supply

drace3000
This post has NOT been accepted by the mailing list yet.
I just received my factory built KX3.  Rig powers on with Eneloop batteries installed.  When I remove batteries and connect at 12VDC battery the rig does not power on.  I measured voltage with VOM at plug end and reads 12.58VDC and connect to KX3 9-15VDC receptical and does not power on.  I switched to another 12VDC source and same result.

Any ideas?

Thank you
Don - KW2AIR
Reply | Threaded
Open this post in threaded view
|

Re: KX3 Does Not Power On with External Power Supply

hb9brj
Two things I would check:
(1) polarity ok (center positive)?
(2) measure battery voltage while it delivers 0.5A or more to any available load.

Markus HB9BRJ
Reply | Threaded
Open this post in threaded view
|

Re: KX3 Does Not Power On with External Power Supply

F5LCI
- Are you using the elecraft 12v power cord ? - Firmly seated ?
(I have had a similar problem with a noname connector whose tip diameter was too large).

- In the menu, what is the status of BAT CHG and of BAT MIN ? (and ALARM ?)

- Have a look inside at the power input connector.

- What happens without the batteries ?

72, Jean-Marc, F5LCI
Reply | Threaded
Open this post in threaded view
|

Re: KX3 Does Not Power On with External Power Supply

drace3000
This post has NOT been accepted by the mailing list yet.
Jean-Marc,

Appreciate the reply and also from others so far today!

- I am using the Right Angle 12v Power Cable that came with the KX3 part no E850524 and made sure it was firmly seated and measured the plug at 12.5 volts with proper polarity. In the menu I have the following settings

BAT CHG - is not installed
BAT MIN - 9.0
ALARM - OFF

- Without batteries and external power connected the KX3 does not power on.  With Eneloop Pro XX batteries installed and external power disconnected the KX3 powers up properly.  

- I looked inside the case and the connector looks to be secure but have not taken it apart to get a closer look.

Any other thoughts!

Thanks again for the reply!
73's Don - KW2AIR





Reply | Threaded
Open this post in threaded view
|

Re: KX3 Does Not Power On with External Power Supply

drace3000
This post has NOT been accepted by the mailing list yet.
In reply to this post by hb9brj
Markus,

Appreciate the response to my inquiry and after taking a fresh look at this the next day I opened the case and tested the power coming into the rig and found that the polarity was indeed reversed at the external battery source.  Once I reversed the leads all is working now.

Thanks again
73's Don - KW2AIR