KX3 Utility will not run

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

KX3 Utility will not run

Could anyone help me with an urgent problem?

I leave on a trip tomorrow.  I was about to update my KX3 firmware,
when I encountered the following weird problem:

When I try to start the KX3 Utility program it now comes up with
"An exception of class NilObjectException was not handled.  The
application must shut down."  This seems to be a KX3 Utility message,
not a OSX message.

I'm running a MacBook Pro OSX 10.6.8 and KX3Utility OSX_1_12_3_26.
It DID work fine the first time I ran the utility today, and I was able to
save the KX3 configuration, check software versions (I have 1.06 in the
KX3) and even changed the CW memories and Banner text.  I then
downloaded the latest Beta software 1.12 (using ftp/safari) and put it in
my Beta folder.  Now, whenever I try to restart the KX3 Utility it comes
up with the above error message.  

This is what I have tried to do to solve the problem, all to no avail:

1. Restarted the MacbookPro several times.
2. Trashed the Utility file and reloaded/reinstalled it from the Elecraft
website, several times.
3. Tried with the USB to KX3 cable inserted or uninserted; the KX3 on
or off, etc.

Once again, note, I can't even get the KX3 Utility to run.  This has nothing
to do with USB cables or downloading, etc.

Any ideas?

Thanks and 73

John, N6JW